KPTree - Home Desktop Setup
Background
I have Windows on my main desk top machine, it is dual boot with Debian/XFCE. I am using Debian almost exclusively now. The BIOS based dual boot works well, I have it defaulting to Debian. I do not currently have a Windows VM setup on my main server. My 3 sons also have computers with Windows on them. Lastly, I am required to used company Windows machines at work. Hence I like to keep a list of my preferred Windows software reasonable up to date.
I have been using Microsoft products for quite some time, starting with MSDOS back in the 80's then Windows 3.0, 3.1, 95, 98, XP, 7, 8, 8.1, 10 and finally 11. (I managed to skip some of the duds, such as ME, 2000 and Vista, although I did occasionally use them on friends, family and work machines. Contrary to all the noise I never had any problems with version 8 & 8.1. I thought ME was bad and Vista too, but as noted basically managed to avoid them in the most part.)
tldr; Old build
Recently my main home office machine failed. I build this computer myself. Basically originally an Intel i7 with the built-in graphics and a 2TB HD, 32GB RAM (16GB would have been enough) and of course a Seasonic 80plus gold power supply. I then quickly replaced with a 500GB SSD, by this time I had my Linux home server running and used this as a NAS for bulk storage and serving. When I set the machine up it was based upon Windows 7 (64bit of course). When Windows 8 came out I upgraded, then Windows 8.1 and finally Windows 10. A few years later I added a Nvidia 960 graphics card, to help breathe a bit of extra life into the machine (and play games better….) I have tried quite a large amount of software on this machine over the period and it was somewhat cluttered, albeit I did run the likes of CCleaner and SystemMechanic to help keep it usable. In any case I tried to load AutoCADLT 2017 on the machine (yes, a licensed version, my being a professional engineer) it worked on the first evening after loading, then the following day ACADLT stopped working. I tried to get it working to no avail and attempted a reinstall, also to no avail. The following day the machine would not run with the dreaded blue screen of death. Nothing I attempted would revive it. So I investigated a clean Windows 10 install. I downloaded a Windows 10 recovery / installation on to a USB. Turns out product code is no longer required, and my registration for this machine is tied to the hardware and my Microsoft account. After this reinstalling Windows 10 was a breeze. My original install was totally shot. Hopefully I did not have any important information left on the local documents directory. Unknown, unlikely, but possible. Helps to have the Linux NAS and Nextcloud working. It is also a reminder to do my NAS and Nextcloud backups. I got to keep on top of this, and need to try to do it every month.
My son got my old machine and I upgraded to a new Intel i9, with 1TB NVM SSD and 16GB RAM. Of course with a Seasonic 660W Titanium power supply. My first water cool CPU, which has been working a treat!. No graphics card yet, would like to get one in the next year or so. My youngest son got this machine in early 2022. I got a new Intel i9 NUC, which I got with 32GB or RAM and 2TB NvME. I am currently using the built-in Intel graphics, but the NUC will allow a lower tier full size graphics card to be installed (graphics cards is primarily limited by 2 bay size, 650W power supply).
The old build from 2011 became very unreliable and was finally fully upgraded in 2025 to the current Intel i5 CPU at that time, with 48GB RAM. I used the NVidia 2060 in this machine for one son.
The old build from 2016 was upgraded in 2023 to a current Intel i% at that time, with 32GB RAM. I use an Intel ARC A770(?) graphics card.
The old 2018 build is currently in disrepair as the son spilled Coke drink on it and it became unreliable and finally fail. The Nvidia graphics card was not doused in Coke and was repurposed as noted previousl. This son got a current 2025 Intel CPU laptop as a replacement and has not got a desk top at the moment. I recently asked for a replacement desktop (for gaming), however as of writing 2026 Jan there seems to be a supply demand imbalance in the industry and all computer pricing has increased enormously in the past 6 months. Further to this Intel just announced their latest CPU range that looks like a significant improvement worth waiting for. (I was seriously thinking given AMD another try, after a bad experience in 2011 on my first home server build.) I also probably need to upgrade a couple of graphics cards the Nvidia 2060 getting long in tooth and needed a new card if I make a new build. Graphics cards are also excessively expensive now.
So below is a list of Windows software often use.
MSWindows 11 - Software Install List
I do not use Windows much at home anymore. I have highlighted the software I still use with a (!), and software I use on my Linux desktop L
Notes on licensed software:
Xplorer2 :- I have gone back to using plan Windows File Explorer. TheXplorer2 licensing requirements were a pain in the arse. I appreciate that the author fairly and reasonably wants to make money from the product he has worked on, however I was primarily using this product at home on a few machines and on a work machine. The author required that I have licenses on every machine. This coupled with learning the interface that is not identical to vanilla File Explorer made me give up on the software. Also, at home I now primarily use Linux desktop for which Xplorer2 does not function. I believe I had 2 for life licenses, although this was for 2 different versions of the application. I suspect the author may have modified the “for life license”? As of 2024 I have not used this product for circa 7 years.
Polyview :- Went the way of the Dodo….. I had a license. I do not regret purchasing this license once off. I got many years of use. It worked really well at the time. I remember sending a query to the author concerning font comparability, circa 2008. He said the program was ANSI font only not compatible with the expanded font set, I forget what it is called now.
VueScan :- simply the best scanner program around, consistently well supported. Multi platformed, Windows, Linux, perhaps Mac.
YouTube Premium Family. As much as I do not like supporting Google / Alphabeta I have been enjoying the use of YouTube Premium and they throw in YouTube Music too. The family like too. Getting rid of the Ads has been wonderful!
Spotify - My son originally wanted this and I ended up going with family option. Have move to YouTube option as it includes YouTube plus Music.
Microsoft PowerToys: Utilities to customize Windows
Some key short cut keys
The Windows key is called the Super or Meta Key on Linux. I will call the Meta key.
So below is a list of special action keys.
Shift (shift key, left or right)
Alt (alt key, left of right)
Ctrl (Control key, left or right)
Meta (Meta, Super or Windows key, left or right)
→ (Right arrow key)
← (Left arrow key)
↑ (Up arrow key)
↓ (Down arrow key)
PgUp (Page up Key)
PgDn (Page Down Key)
Always on Top
FancyZones
Software Licenses and Copyright
I am not overly pious about free versus purchased software. I appreciate people should be rewarded for their efforts. One has to have the upmost respect for those providing “free” software (true free, e.g. GNU free, NOT Facebook or Google free) . Sadly in general paid software providers merit less respect.
I suppose the problem is the middle man, usually representing wealthy entitled people that use wealth and power to further their power and wealth.
I have the following 2 personal examples that highlight why I do not like paid licensed software.
A very big problem with paid licenses is the common absurd software licenses that go with them. They are a disgrace. Generally they enormously limit the paying end users rights. They are also so long who would bother reading them anyway. Ultimately, if one has paid to use the software one should have the right to use, otherwise why pay.
Autodesk License
I had for many years a license for Autodesk AutoCAD Light. This was not cheap software costing on average a few hundred dollar per year for the right to use. My personal use was very limited, but I wanted access to this software. I did use this software at work too, I could guarantee I was the only person using this license at any one time. Autodesk charges different prices for their product in different countries, there are some valid reasons for this, but the main reason is to do with maximizing profit, in wealthier countries they can simply get away with charging more, in poor countries generally less. Also there are marketing reasons in populous countries they may charge lower pricing to increase market penetration and make more sales, hence overall more profit. Sadly I come from a relatively wealthy country with a relatively small population, read higher pricing! The argument from the seller is that is cost more to sell in my country, however being English speaking I would be quite happy to use the USA version of the software at the USA price! Basically many USA aspects are forced down our throat anyway, e.g. date format.
In any case I was assigned to work in China for about a year. About 3-4 months working in China I had a call from the company software department to ask if I was using AutoCAD Light software. I said yes, but with paid for license. Nevertheless they asked that I remove the software from the company computer, to which I immediately acquiesced. Upon reading the license for the produce I found I only had the right to use the software in another country for 90 days after which I was expected to purchase a local version there! Like I was expected to purchase a Chinese license of the software. This was totally unacceptable and really is an example of gross license conditions failure.
I still use Autodesk products at Work using the license provided from work. These are often corporate based network licenses that only work if connected to the network. There is a method to fix a license to a machine, if required.
xplorer2
xplorer2 is a nice Windows File Explorer replacement with many extra features. I used for a number of years, but again the licensing requirement just became more than they were worth for me.
I purchased a copy for personal home use and another copy for work use. The license is tied to a particular computer on to which the software is installed and authorised for use. I have a number of computers at home, and generally only one at work. It was basically required that I have a license for every computer at home, I could not justify the expense and inconvenience associated with swapping active license on machines at home. I asked to install the license on more than one machine and the response was basically one license one machine!
Basically the built in version of File Explorer in Windows meets 95+% of my daily needs.
An additional problem with using xplorer2 was that I got use to using it and when I went back to standard File Explorer it was uncomfortable to use. As this software is basically on every Windows machine this happened often. So I have simply stopped using xplorer2 at work and at home, it is simply not worth the trouble, particularly with the restrictive license requirements.
Ultimately the software owner has the right to limit their software to 1 machine per license, however I have the similar right to decided this means the software it too expensive and inconvenient for me to justify to use. For this type of software I want a license that gives me unfettered home use on at least 2 machines and perhaps all home personal use machines, with a separate license for work use.
Foxit Pro / Qoppa
Sadly there is no full featured GNU Licensed Linux PDF writer. Further to this most paid versions, including Foxit Pro do not work on Linux. Interestingly the Free version of Foxit does have a Linux version. Hence I purchase a copy of Qoppa Software's PDF Studio PRO that does run of Linux and Windows. I may end up buying another license of Qoppa for my work machine in the future if happy with it, instead of Foxit Pro.
I was quite happy with Foxit Pro on Windows, but if they can not provide a Linux version… Also Foxit originally allowed 2 installations per license and now seem to be going back to 1 machine one “Single-Use” license, which is a problem for me. Qoppa states“…can be used on 2 machines of any OS.”
Software Bigotry
Licensed software is often full of terms that are arguably bigoted, however this is usually simply a goal to maximize profit. Sadly some GNU software providers seem to provide limits on their software use based upon their biases.
iTunes - setup
I hardly ever use iTunes any more
iTunes is software I do not particularly like. First of all I do not use the Music feature having long ago rip my CD collection to MP3 and I simply do not like the way iTunes works. So the only real reason to use iTunes is for my iOS devices, backing up iOS devices etc. iTunes, in typical Apple fashion I find is not smart end user friendly as it has been designed for not smart users and attempts to hide the lower level file system. Further to this the configuration, backups and apps end up being very large amounts of files (multiple 1000s) and using huge amounts of disk space, in some cases well over 200GB!. So to help alleviate the excessive file system use on my primary Windows10 SSD I would like to move to my Linux NAS. The following are the steps to achieve this.
I really now only use this software to backup and restore Apple devices…. The app functionality has been removed by Apple, which is good as I was wasting too much of my time….. Otherwise iTune is and always has been crap ware…..particularly on MSWindows machine.
Download from Apple and install the latest Windows 10 64bit version of iTunes.
Run iTunes and check the location of the “iTunes Media folder location” found in the menu item: Edit, Preferences, Advanced tab. e.g. “C:\Users\doej\Music\iTunes\iTunes Media”
Stop iTunes running
If moving an exiting iTunes data directory first time, copy C:\Users\doej\Music\iTunes to \\NASname\various_path\iTunes
Rename C:\Users\doej\Music\iTunes to C:\Users\doej\Music\iTunes_old, or simply delete.
Open Administrator Command Prompt(right click windows start and select so). Then run following command to create a simlink to NAS stored iTunes library: mklink /D 'C:\Users\doej\Music\iTunes' \\NASname\various_path\iTunes. The command should state symbolic link created as given in original command.
The backup files are found at: C:\Users\baumk\AppData\Roaming\Apple Computer\MobileSync\Backup.
Often the backup will not work or be seen. The solution is to move to another directory and then add back to the official directory until the correct backup directory is found or until adding one stops iTunes from working. More shoddy Apple software……
iTunes - Not Recognising Devices
iTunes is a pretty flakey program and Apple does play the propriety with the Lightning cable, so the problem could be any of the following:
Bad cable
Bad USB driver
Bad USB port
iTunes playing up
However one good trick is to simply run the install file “C:\Program Files\Common Files\Apple\Mobile Device Support\Drivers\usbaapl64.inf”. The easiest way being to right click the file in exploer and select the install option.
Printer Scanner Setup
With the problems on the old printer noted below I decided to replace the printer scanner. After 4 year of use it looks like I made the correct decision to go with the lower priced larger A3 printer with disposable ink cartridges.
I looked at 2 main options:
An A3 multi function from Epson the WF-7725, this is the option I went with.
The printer cost is about 2x the large ink cartridge pack cost. Which at 4 years I have only purchased 2 times. I need to purchase a spare again soon.
The printer and scanner are full A3, including the ADF!
Everything has been working well after 4 years. The ADF (Automatic document feeder) was nice to use, compared to the old manual single page scanner! I do need to try to run the printer monthly to prevent the nozzles from blocking.
The A4 paper cassettes must be setup as portrait not landscape. But should not be problem for bubble jet printer. So a non-issue.
The machine is not exceptionally fast, but not a problem for a home office unit. More important is ease of use, long term reliability, and cost to run - read ink cost. I try to limit my printing and have not printed to any photo paper. After about 7 months I had to replace the black ink cartridge. The ink cost seem OK for low volume printing. The scanner works great both platen and auto document feeder. The auto document feeder is more sensitive that the pro office printers, but works well.
The Epson print and scan software worked well on MSWindows10. The ADF scanner scanned a pdf straight to the local computer document directory using the scanner program supplied.
An A4 multifunction from Canon or Epson with large refillable ink tanks
I looked at the various product review and in general print quality and functionality were commented on as substandard. Looks like these unit still need more polish before they become mainstream. This was the main show stopper for me. In any case after 2-3 year I can always upgrade the printer again, if necessary.
A colleague at work mention that the functionality of the Epson Ecotank multifunction A4 he purchased was poorer that his previous generation HP printer.
The up front cost is higher, however usually include 2 years of ink, so is competitive cost-wise in this consideration.
The A3 version of this printer was significantly more expensive (x5 the WF-7725 cost)
Old Printer
tldr;
I finally stopped using the printer after over 8 years of use in 2019, it was a Canon MP990 multi-function.
Canon seem to not be supplying an updated driver after Windows 8.1, that is, no Windows 10 drivers. I suspect there are 3 reasons for this; first, due to the age of the printer the vendor does not wish to spend the money to update the drivers, and second, the vendor hopes that users will simply purchase a new printer! Fortunately the default MSWindows 10 printer driver seems to work adequately with most required options. Unfortunately, the MSWindows scanner driver options are very limited. I attempted to load the OEM Windows 8.1 drivers, however they did not seem to recognise the printer. So I found a suitable free scanner driver that give the basic required scanner functionality, xxxNAPS2xxx, however the functionality proved to be too limited. I found and purchased a copy of Vuescan and now use this, it is very good and not tied to any particular printer supplier.
About the last 2 years of use I started to use cheaper compatible ink - this was a mistake. It is simply not cheaper! As the printer is less reliable as before just about each use needs to perform the deep nozzle clean. The deep nozzle clean uses so much ink that I run out of ink much faster so the cost saving is negligible. I suspect part of the problem is that I only use the printer every 1-2 months and the compatible ink has greater propensity to dry-up and plug nozzles more than original ink did.
I always felt the original Canon software was quite bloated.
Offsite Printing
Printing photos at home is very expensive. The photo paper and original ink are just too expensive (rip off). It is cheaper to setup the photos and get their files printed at the likes of Kmart. These photo printing services even have on-line services or take a USB drive to the store terminal. The photos get mailed to you.
Old printer stuff
Windows Drive Link / Substitution
In windows both the link and drive substitution commands have their own nuances….. The main problem with “subst” is that the reference is not canonical. The mklink seems to sometimes fall back to the full path.
There are two main reasons to use:
To overcome the path/name length restriction of 260 characters
To simply the path name of regularly used references.
In Linux symlinks seem to be more robust (mind you just about everything seems more robust…) Symlinks to files are used as a control mechanism. Hard links are frequently used as a backup technique to minimise real backup space used.
Windows file manager webDAV Nextcloud setup
Map a network drive using:
https://cloud.kptree.net/remote.php/dav/files/USERNAME/
Windows Symlink equivalent command - mklink
For some reason Windows 10 will not show my network drives in the Explorer Network directory. Even when it did work it was slow to show the network drives. I can simply type in the network drive into the path, e.g. “\\User1NetworkDrive”, but this is a bit clumsy and is not always an option in some file modal windows. A symlink is the best overall solution.
Open up a Command Prompt (Admin) - right click the windows icon or type “Win + X”. In Windows 10 you can also type in Command into the Cortina search area and right click on the Command Prompt item.
For files the command syntax is: “mklink Link Target”.
I am only really interested in a directory link the syntax is: “mklink /D Link Target”, example: “mklink /D C:\Users\User1\User1NetworkDrive \\User1NetworkDrive”.
Windows Drive Substitution - subst
This is the command syntax to associate a path with a drive letter:
SUBST [drive1: [drive2:]path]
SUBST drive1: /D
Parameters
drive1: – Specify a virtual drive to which to assign a path.
[drive2:]path – Specify a physical drive and path to assign to a virtual drive.
/D – Delete a substituted (virtual) drive.
Using the SUBST command with no parameters will display a list of current virtual drives.
The GUI option in Windows is to right click the network icon in file explorer. Then select the option map network drive. A similar option to Disconnect network drive exists.
There is an “opposite” to the “subst” command called “join” that makes hardward devices appear as directories.
Windows Keyboard Mapping Problems
All too often the keyboard mapping seems to get set to the United Kingdom, which messes up a few of the Keys when using a US keyboard. I suspect this is a problem with selecting Australian as the primary English langage that seems to sometime also select the UK keyboard. In any case in Windows 10 the solution is as follows.
The simple solution is to remove the UK language setting and if necessary add the US one. The Australian can remain. Further to this the keyboard layout can be independantly set. The language can be adjusted in the “ region and language setting”, use Cortana if necessary to find. Click on the language and add the US QWERTY if necessary. Delete the UK QWERTY keyboard layout.
Windows Off Screen Problems
I have had problems with windows appearing off the screen partially or fully many times over the years, particularly when using multiple monitors.
I found an article on CNet, but will not link to it, as CNet is a real garbage filled site. In any case the simple solutions are listed below:
Right-click on the taskbar and click Cascade windows. This will reset all open window positions and cascade them from the top left screen point. Unfortunately, many media players will not reposition in this manner, and it forces ALL of your windows to reposition – even the ones that were behaving themselves.
Right click on the task bar icon for the specific program and select move. Use the mouse or keyboard direction arrows to move the window selected.
Right click on the task bar icon for the specific program and select Maximise. The window will maximise to the full screen area. When minimised its position will return to previous off screen.
For Windows 10 you need to move over the task bar program until the small program window appears, this also bring to foreground the main window too. Then right click on the small program window to get the move and maximise options.
Windows 11 Multitasking / Screen Control
Powertools Screen control key set: windows + shift + `
Multitasking setting (windows + i then select multitasking (under system))
Snap Windows options
Alt Tab options
Windows 11 File Explorer options
Powertools Screen control key set: windows + shift + `
For developers (windows + i then select for developers (under system))
Web Page Favorites Save/Restore
MS Edge
Save Favorites
Open Microsoft Edge
Click More (three dots) in the top right corner of your browser window
Click Favourites
Click More Options (three dots)
Click Export Favourites
Choose where to export your favourites (Folder in your OneDrive)
Click Save to finish.
Note: Microsoft Edge exports your bookmarks as an HTML file. Use this file to import your bookmarks into another browser.
Import Favorites from a HTML file
Open Microsoft Edge
Click Settings and More (three dots) in the top right-hand corner of your browser window (alternatively click ALT + F)
Click Settings
Click Import Browser Data
Navigate to Import from Other Browsers > Click Choose what to import
Select Favorites or Bookmarks
HTML file as the 'import from' location.
Click Choose File
Search and Select the favorites or bookmark
HTML file
Click Open.
When the import is complete you will receive a notification, Click Done.
Firefox
Save Favorites
Open Firefox
Click Show your bookmarks
Click Show All Bookmarks
Click on the Import and Backup tab
Click Export Bookmarks to
HTML
Navigate to the appropriate folder in your OneDrive
Enter a file name for the export
Click Save
Chrome
Open Chrome
Click More (three dots) in the top right-hand corner of your browser window
Click Bookmarks and lists
Click Bookmark Manager
Click More (three dots) in the top right-hand corner > Click Export Bookmarks
Note: Chrome exports your bookmarks as an
HTML file. Use this file to import your bookmarks into another browser.
MSExcel Tips
Show 2 sheets of same file
Use the menu VIEW ⇒ New Window to open a new window in the active workbook
MS Excel Highlight Row or Column
The basic built in way :
Use conditional formating, but this requires hitting F9 or a VB macro to actually highlight.
Use a VB macro. Main down side to this is that it slows down the MSExcel performance
VB Code 1
'from https://www.exceldemy.com/learn-excel/highlight/row/
Private Sub Worksheet_SelectionChange(ByVal Target As Range)
If Target.Cells.Count > 1 Then Exit Sub
Application.ScreenUpdating = False
'Clear the color of all cells
Cells.Interior.ColorIndex = 0
With Target
'Highlight row and column of the selected cell
.EntireRow.Interior.ColorIndex = 38 'or use RGB(200,200,200) to pick a colour
.EntireColumn.Interior.ColorIndex = 24
End With
Application.ScreenUpdating = True
End Sub
VB Code 2
'from https://www.howtoexcel.org/highlight-current-row-column/
Sub Worksheet_SelectionChange(ByVal Target As Excel.Range)
Static xRow
Static xColumn
If xColumn <> "" Then
With Columns(xColumn).Interior
.ColorIndex = xlNone
End With
With Rows(xRow).Interior
.ColorIndex = xlNone
End With
End If
pRow = Selection.row
pColumn = Selection.Column
xRow = pRow
xColumn = pColumn
With Columns(pColumn).Interior
.ColorIndex = 6
.Pattern = xlSolid
End With
With Rows(pRow).Interior
.ColorIndex = 6
.Pattern = xlSolid
End With
End Sub
Text to Column
When pasting text from other applications on occassions Excel places all the columns into one column. To adjust into multiple columns the following feature can be used. Menu: Data : Text to Columns
Text Carriage Return / Line Feed
ON Mac/Linux this may be char(13) due to different ways these OS handle carriage return / end of line and line feed control charaters.
List Windows files and directories into MSExcel
The menu : Data : Get Data : From File : From Folder presents a dialogue to input a windows directory. Once the directory is shown the load button will place it into a new sheet
MSExcel List file path and name in cell
=CELL(“filename”,A1)
The cell function returns information about the cell contents.
List Directories to csv file
This is performed in MSWindows Powershell using command: dir -Recurse -Directory | Select FullName | Export-Csv “list.csv”
After this I want to list the level of the directory, to do this I count the number of “\” in cell B3: =LEN(B3)-LEN(SUBSTITUTE(B3,“\”,“”))
MSExcel Visual Basic
friction factor calculation
Earlier in my engineering career I used Lotus123 and MSExcel with iteration to calculate the friction factor of piping with Newtonian fluid according to the Darcy friction factor formulae. To remove the iteration from the spreadsheet I wrote a simple VB script that took care of this. When I get the change I will copy the script here.
VSBasic code for Colebrook Equation
'Public Re As Double 'Reynold number unitless 0<Re<10E9
'Public Rr As Double 'Relative Roughness unitless
Public Ff As Double 'Friction Factor unitless
Public Fnew As Double
Public error As Double
Public i As Integer
Public Function Pipefriction(Re, Rr)
'
' Calculated Moody Friction Factor for fluid flows
'
'https://en.wikipedia.org/wiki/Darcy_friction_factor_formulae
'
'The log function is understood to be base-10 (as is customary in engineering fields): if x = log(y), then y = 10x.
'Hence, Loge(10)=2.30258509299405, 2/loge(10)=0.8685889638065
'
Ff = -1
i = 0
If Re > 0 And Re <= 2000 Then
Ff = 64 / Re
ElseIf Re > 2000# And Re < 90000000000# And Rr > 0 And Rr < 0.01 Then
Ff = 0.015
Do
' Fnew = 1 / (2 * Log10(Rr / 3.7 + 2.51 / (Re * Ff ^ 0.5))) ^ 2
Fnew = 1 / (0.8685889638065 * Log(Rr / 3.7 + 2.51 / (Re * Ff ^ 0.5))) ^ 2
error = Abs(Fnew - Ff) / Fnew
Ff = Fnew
i = i + 1
Loop Until error < 0.00001
End If
Pipefriction = Ff
End Function
'Static Function Log10(X)
' Log10 = Log(X) / Log(10#)
'End Function
As can be seen in the wiki page, Darcy friction factor formulae, there are reasonably accurate equations that approximate the Colebrook equation that are available that do not require iterations to solve. I believe the VBscript is simpler and not an approximation…..
MSExcel unnecessarily and annoyingly changes conditional formatting ranges.
The options menu, advanced options, Editing options, unselect Extend data range formats and formulas reputedly stops this behavior. Unfortunately, it also stops the automatic copying of formula when inserting new rows or adding new lines to the bottom of an existing list.
References:
MSExcel Page Layout Margin Unit
I really have the hard default to the archaic units. Finding the options to set to metric is too difficult.
Options → Advanced Setting
Display section
Ruler Units: set to mm here
MS Word
One of the biggest problems with MSWord, like almost all USA software is seemingly hard defaults to the inch system and US paper system. I do not like using this system and prefer the metric system and ISO A series paper size. I wish there was some way to isolate of other wise remove the USA measurement system and paper sizes.
TOC (Table of Content Switches
Soft and Hard Return and Page Break and Section Breaks
Hard Return: A hard return is created by pressing the Enter key. This action signifies the end of a paragraph and the beginning of a new one. It is visually represented in Word as a paragraph mark (¶) when non-printing characters are displayed. Hard returns help organize text into distinct sections, making documents easier to read and navigate.
Soft Return: A soft return, also known as a line break, is created by pressing Shift + Enter. This action moves the cursor to the next line without starting a new paragraph. Soft returns are useful for formatting text within the same paragraph, such as in lists or when you want to break a line without creating additional spacing that a hard return would introduce.
Page break: A page break is created by pressing Ctrl + Enter. These create a break between pages in your document, allowing you to start a new page without affecting the layout of the previous pages. They only partition the body text of the document.
Section Breaks: There is no standard keyboard entry for section breaks. Section breaks are inserted from the menu ribbon, under layout → breaks (in the page setup ribbon) These allow you to change the layout or formatting of a section of your document. They can partition not only the body text but also headers, footers, page numbers, and margins, enabling different formatting within the same document.
Usage: Use page breaks for simple page transitions, while section breaks are useful for more complex formatting needs, such as changing the number of columns or page orientation within a document.
MS Word and Excel Keyboard Shortcuts
Replace File menu commands:
Ctrl-p for print dialogue
Ctrl-S or Shift-F12 for save
F12 for save-as
%Ctrl-w to close the current document
*%Ctrl-n or Ctrl-Alt-F2 to create new document
Frozen Program Safe Start
Sometime a program seems to get stuck when starting. This could be the add-in or other problems. A possible solution is to start the program in safe mode.
Open up run (Windows + R)
Type name of program with /safe, e.g. outlook.exe /safe, word.exe /safe or excel.exe /safe
Sometime this is enough to allow a normal restart
Check add-ins and stop start-up
Some other possible options to check:
Create PDF with bookmarks from headings
I am noticing many pdfs being deliver now without any bookmarks included or garbage bookmarks. Larger pdfs e.g. over 30 pages should always be bookmarked, this is a kep benefit of online documents to allow quick navigation within the document. This is a key feature that can make online documents easier to use than hard copies. MSWord does have the option to create pdfs with bookmarks developed from the built in headings.
Open the Word document and ensure you have used built-in heading styles (e.g., Heading 1, Heading 2) for the sections you want as bookmarks in the PDF.
Click on File in the top menu and select Save As.
Choose a location to save the file and select PDF from the Save as type dropdown menu.
Click on the Options button in the Save As dialog box.
Under the Include non-printing information section, check the box for Create bookmarks using and select either: Headings (to use Word's heading styles as bookmarks), or Word bookmarks (if you manually created bookmarks in Word).
Click OK to confirm the options and then click Save to generate the PDF with bookmarks.
If the bookmarks still do not appear, try using the Export feature: Go to File > Export > Create PDF/XPS Document. Click Options and ensure the Create bookmarks using option is selected.
If the issue persists, consider using Adobe Acrobat to create the PDF, as it may handle bookmarks more reliably in some cases.
Show
Autodesk
AutoCAD
AutoCAD Hardware Acceleration
The Intel built in graphics accelerator seems to have problems with proper full screen resolution on 4K monitors. A solution to rectify this is to turn off the hardware acceleration within the AutoCAD product, see How to enable or disable hardware acceleration in AutoCAD. The hardware configuration option can be found using the following commands: graphicsconfig, 3Dconfig, options.
Annotative block
If inserting block does not seem to scale or show up check the annotative option on the block properties. The option can only be changed in block edit.
Inserting a Picture
Attaching a picture effectively externally references the picture. Unlike a drawing xref these ole object do not seem to be able to be bound (embedded) to the drawing. This is subject to links path breakage, particularly on multiuser system. Where the image is in the same directory the path can be specified as “./image.file”.
Use the PASTESPEC command and paste in as a picture file. This embeds into drawing file, not as a link. The image in the clipboard is used. Usually, the image needs to be copied to the clipboard via a image program. A bit clunky…..
New Paperspace View port
STYLEMANAGER
The command STYLEMANGER opens up the directory where the plot styles are stored. Different plot styles can be copied to and from this directory.
Line Weights
LWEIGHT opens Lineweight Setting dialog box
LWDISPLAY set to 0 (off) will hide display lines weight, set to 1 (on) will display line weights.
LWDEFAULT changes the default line weight size.
0 will use thinness line supported by printer.
Otherwise, line thickness set to hundredths of millimeters, values from 0 - 2540 hundredths of millimeters.
CELWEIGHT sets line weight of new objects:
-1, Sets the lineweight to “BYLAYER.” (Default).
-2, Sets the lineweight to “BYBLOCK.”.
-3, Sets the lineweight to “DEFAULT.” Where “DEFAULT” is controlled by the LWDEFAULT system variable.
Other valid values entered in hundredths of millimeters, from 0 to 2540 hundredths of millimeters.
XREF Layer control
Issue: Changes to an External Reference (Xref) do not show up when reloading the Xref in AutoCAD products. Such changes include:
Layer line type.
Layer line thickness.
Layer color.
Layer transparency.
Elements added or deleted.
Additionally, the Xref may update in the base drawing without issue when a different layer with the same properties is chosen.
Causes:
The VISRETAIN system variable is set to 0.
The VISRETAIN system variable is set to 1 and the VISRETAINMODE system variable is set to 0.
XREFOVERRIDE is set to 1.
Corrupted file.
Corrupted AutoCAD profile.
Changes are being made in paper space
VISRETAIN
| Value | Descritption |
| 0 | The layer table, as stored in the reference drawing (xref), takes precedence. Changes made to xref-dependent layers in the current drawing are valid in the current session only and are not saved with the drawing. When the current drawing is reopened, the layer table is reloaded from the reference drawing, and the current drawing reflects all of those layer property settings. |
| 1 | Xref-dependent layer changes made in the current drawing take precedence. Layer settings are saved with the current drawing's layer table and persist from session to session. (default) |
VISRETAINMODE
Controls the behavior of the VISRETAIN system variable when it's set to 1.
Use this system variable in conjunction with the VISRETAIN system variable to control which xref layer properties that you want to automatically sync on reload.
Note: Xref layer properties with overrides are not synced when the xref is reloaded. To clear any overrides, use the shortcut menu option, Reset Xref Layer Properties For, on the Layer Properties Manager.
| Value | Description |
| 0 | No settings are synchronized. You will have the same experience when you set VISRETAIN to 1 in AutoCAD 2017 or earlier. (default) |
| 1 | On/Off synchronized. |
| 2 | Freeze/Thaw synchronized. |
| 4 | Lock/Unlock synchronized. |
| 8 | Plot/No Plot synchronized. |
| 16 | Color synchronized. |
| 32 | Linetype synchronized. |
| 64 | Lineweight synchronized. |
| 128 | Transparency synchronized. |
| 256 | Plot style synchronized. |
| 512 | New VP Freeze synchronized. |
| 1024 | Description synchronized. |
To specify more than one layer property to sync, enter the sum of the bitcode values. For example, a value of 3 specifies that both the On/Off (1) and Freeze/Thaw (2) layer properties will automatically sync when the xref is reloaded.
XREFOVERRIDE
Controls the display of object properties on referenced layers.
The XREFOVERRIDE system variable affects display and plotting, and works in conjunction with the VISRETAIN system variable. If you want the xref layers to retain their original layer settings, it is recommended to set VISRETAIN and XREFOVERRIDE system variables to 0.
| Value | Description |
| 0 | When the properties of the objects (such as color, linetype, lineweight, transparency, or plot style) on the external reference drawing are set to ByLayer, any changes to the xref layer properties are displayed in the current drawing (legacy behavior) (default) |
| 1 | When the visual properties of the objects on the external reference drawing are not set to ByLayer, objects on xref layers are treated as if their properties are set to ByLayer and every external reference layer can have its own set of layer overrides |
Note: The XREFOVERRIDE system variable only applies to DWG xrefs, not to other references such as underlays.
References
Accessibility Contract Checker
Form versus function, unfortunately the moronic types seem to favour form over function. Contrast of text is particularly important to allow easier reading.